Failed to restart Apache while installing mod_pagespeed

December 29, 2014 1.7k views

I was trying to install mod_pagespeed, after installing when I tried to restart Apache, I am getting this error:

[root@webuzo ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: apr_sockaddr_info_get() failed for webuzo
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]
2 comments
  • Are you running another web service like nginx on your droplet? The error shown indicates that when trying to start apache found port 80 was already in use by another process.

  • I am using Webuzo Web Hosting Control Panel.

2 Answers

hi

simple solution kill all process in shell
and then restart the apache

hi guys , i am facing same error i tried and resolve it ..

[root@Aako subsys]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using Aako.com for ServerName
(98)Address already in use: makesock: could not bind to address [::]:80
(98)Address already in use: make
sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[FAILED]

[root@Aako subsys]# ps -ef |grep httpd*
500 21161 20760 0 Jul25 pts/8 00:00:00 /bin/sh /sbin/service httpd restart
500 21168 21161 0 Jul25 pts/8 00:00:00 /bin/bash /etc/init.d/httpd restart
apache 28863 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
apache 28864 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
apache 28865 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
apache 28866 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
apache 28867 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
apache 28868 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
apache 28869 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
apache 28870 1 0 10:56 ? 00:00:00 /usr/sbin/httpd
root 29146 19834 0 11:01 pts/6 00:00:00 grep httpd*

[root@Aako subsys]# kill -9 28863 28864 28865 28866 28867 28868 28869 28870
[root@Aako subsys]# ps -ef |grep httpd*
500 21161 20760 0 Jul25 pts/8 00:00:00 /bin/sh /sbin/service httpd restart
500 21168 21161 0 Jul25 pts/8 00:00:00 /bin/bash /etc/init.d/httpd restart
root 29156 19834 0 11:01 pts/6 00:00:00 grep httpd*

[root@Aako subsys]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using Aako.com for ServerName
[ OK ]
[root@Aako subsys]#
[root@Aako subsys]#
[root@Aako subsys]# service httpd status
httpd (pid 29174) is running...

Now working fine ...

Have another answer? Share your knowledge.