Question

Getting 404 errors

Hello, I had a wordpress site which is (http) on Godaddy before. I moved it to DigitalOcean with an SSL(https). But after moving the website and updating URL, I get 404 errors. I’ve done pretty much every suggestion mentioned online, that includes:

  • Updating permalinks in wordpress
  • enabling mod_rewrite
  • Giving necessary permissions to .htaccess file
  • Purging caches

Please help. My site is fine but I cannot view images or click on links (They show 404 errors).

Website url is https://www.gtadb.net/


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

In the code 404, the first digit indicates a client error, such as a mistyped Uniform Resource Locator (URL). The following two digits indicate the specific error encountered. A 404 error is often returned when pages have been moved or deleted.

I found out the error is occuring due to setting custom permalinks. The default permalinks dont throw 404 errors. Any solution for this? I’ve enabled mod_rewrite, given .htaccess enough permissions etc.

I have already changed it quite before when I set up my SSL.

https://gyazo.com/5ba48a5fe7aa62fb6577925bffe5db40

Error 404 still occurs.