Question

Help with Apache on Centos droplet

Posted November 23, 2014 4.3k views

I just installed Apache onto my Centos 7 droplet following the instructions, however when I go to my web browser and put in my ip address nothing comes up. I’m not sure what I’m doing wrong but I’d love some feedback.

Thanks

4 comments
  • Hi! Are there any errors in Apache’s log file?

    sudo tail -40 /var/log/httpd/error_log
    
  • Here’s what I see.

    [Sun Nov 23 11:49:26.210114 2014] [mpmprefork:notice] [pid 27378] AH00163: Apac
    he/2.4.6 (CentOS) configured – resuming normal operations
    [Sun Nov 23 11:49:26.210142 2014] [core:notice] [pid 27378] AH00094: Command lin
    e: ’/usr/sbin/httpd -D FOREGROUND’
    [Sun Nov 23 11:50:43.243676 2014] [mpm_prefork:notice] [pid 27378] AH00170: caug
    ht SIGWINCH, shutting down gracefully
    [Sun Nov 23 11:50:44.296893 2014] [suexec:notice] [pid 27418] AH01232: suEXEC me
    chanism enabled (wrapper: /usr/sbin/suexec)
    [Sun Nov 23 11:50:44.308104 2014] [auth_digest:notice] [pid 27418] AH01757: gene
    rating secret for digest authentication …
    [Sun Nov 23 11:50:44.308865 2014] [lbmethod_heartbeat:notice] [pid 27418] AH0228
    2: No slotmem from mod
    heartmonitor
    [Sun Nov 23 11:50:44.314692 2014] [mpmprefork:notice] [pid 27418] AH00163: Apac
    he/2.4.6 (CentOS) configured – resuming normal operations
    [Sun Nov 23 11:50:44.314737 2014] [core:notice] [pid 27418] AH00094: Command lin
    e: ’/usr/sbin/httpd -D FOREGROUND’
    [Sun Nov 23 11:51:49.536091 2014] [mpm_prefork:notice] [pid 27418] AH00170: caug
    ht SIGWINCH, shutting down gracefully
    [Sun Nov 23 11:51:50.581858 2014] [suexec:notice] [pid 27453] AH01232: suEXEC me
    chanism enabled (wrapper: /usr/sbin/suexec)
    [Sun Nov 23 11:51:50.592493 2014] [auth_digest:notice] [pid 27453] AH01757: gene
    rating secret for digest authentication …
    [Sun Nov 23 11:51:50.593160 2014] [lbmethod_heartbeat:notice] [pid 27453] AH0228
    2: No slotmem from mod
    heartmonitor
    [Sun Nov 23 11:51:50.595319 2014] [mpmprefork:notice] [pid 27453] AH00163: Apac
    he/2.4.6 (CentOS) configured – resuming normal operations
    [Sun Nov 23 11:51:50.595344 2014] [core:notice] [pid 27453] AH00094: Command lin
    e: ’/usr/sbin/httpd -D FOREGROUND’
    [Sun Nov 23 11:54:42.477226 2014] [mpm_prefork:notice] [pid 27453] AH00170: caug
    ht SIGWINCH, shutting down gracefully
    [Sun Nov 23 11:54:43.526864 2014] [suexec:notice] [pid 27526] AH01232: suEXEC me
    chanism enabled (wrapper: /usr/sbin/suexec)
    [Sun Nov 23 11:54:43.538151 2014] [auth_digest:notice] [pid 27526] AH01757: gene
    rating secret for digest authentication …
    [Sun Nov 23 11:54:43.538948 2014] [lbmethod_heartbeat:notice] [pid 27526] AH0228
    2: No slotmem from mod
    heartmonitor
    [Sun Nov 23 11:54:43.541867 2014] [mpmprefork:notice] [pid 27526] AH00163: Apac
    he/2.4.6 (CentOS) configured – resuming normal operations
    [Sun Nov 23 11:54:43.541896 2014] [core:notice] [pid 27526] AH00094: Command lin
    e: ’/usr/sbin/httpd -D FOREGROUND’
    [Sun Nov 23 11:58:38.913367 2014] [autoindex:error] [pid 27528] [client 104.131.
    105.82:36071] AH01276: Cannot serve directory /var/www/html/: No matching Direct
    oryIndex (index.html) found, and server-generated directory index forbidden by O
    ptions directive
    [Sun Nov 23 12:09:55.330214 2014] [mpm_prefork:notice] [pid 27526] AH00170: caug
    ht SIGWINCH, shutting down gracefully
    [Sun Nov 23 12:09:56.387437 2014] [suexec:notice] [pid 27901] AH01232: suEXEC me
    chanism enabled (wrapper: /usr/sbin/suexec)
    [Sun Nov 23 12:09:56.399786 2014] [auth_digest:notice] [pid 27901] AH01757: gene
    rating secret for digest authentication …
    [Sun Nov 23 12:09:56.400653 2014] [lbmethod_heartbeat:notice] [pid 27901] AH0228
    2: No slotmem from mod
    heartmonitor
    [Sun Nov 23 12:09:56.403557 2014] [mpmprefork:notice] [pid 27901] AH00163: Apac
    he/2.4.6 (CentOS) configured – resuming normal operations
    [Sun Nov 23 12:09:56.403584 2014] [core:notice] [pid 27901] AH00094: Command lin
    e: ’/usr/sbin/httpd -D FOREGROUND’
    [Sun Nov 23 12:12:47.910905 2014] [mpm_prefork:notice] [pid 27901] AH00170: caug
    ht SIGWINCH, shutting down gracefully
    [Sun Nov 23 12:19:43.658455 2014] [suexec:notice] [pid 28548] AH01232: suEXEC me
    chanism enabled (wrapper: /usr/sbin/suexec)
    [Sun Nov 23 12:19:43.674465 2014] [auth_digest:notice] [pid 28548] AH01757: gene
    rating secret for digest authentication …
    [Sun Nov 23 12:19:43.675422 2014] [lbmethod_heartbeat:notice] [pid 28548] AH0228
    2: No slotmem from mod
    heartmonitor
    [Sun Nov 23 12:19:43.686596 2014] [mpmprefork:notice] [pid 28548] AH00163: Apac
    he/2.4.6 (CentOS) configured – resuming normal operations
    [Sun Nov 23 12:19:43.686659 2014] [core:notice] [pid 28548] AH00094: Command lin
    e: ’/usr/sbin/httpd -D FOREGROUND’
    [Sun Nov 23 12:24:19.640183 2014] [mpm_prefork:notice] [pid 28548] AH00170: caug
    ht SIGWINCH, shutting down gracefully
    [Sun Nov 23 12:24:20.693550 2014] [suexec:notice] [pid 28677] AH01232: suEXEC me
    chanism enabled (wrapper: /usr/sbin/suexec)
    [Sun Nov 23 12:24:20.703738 2014] [auth_digest:notice] [pid 28677] AH01757: gene
    rating secret for digest authentication …
    [Sun Nov 23 12:24:20.704434 2014] [lbmethod_heartbeat:notice] [pid 28677] AH0228
    2: No slotmem from mod
    heartmonitor
    [Sun Nov 23 12:24:20.710113 2014] [mpm_prefork:notice] [pid 28677] AH00163: Apac
    he/2.4.6 (CentOS) configured – resuming normal operations
    [Sun Nov 23 12:24:20.710137 2014] [core:notice] [pid 28677] AH00094: Command lin
    e: ’/usr/sbin/httpd -D FOREGROUND’
    [Sun Nov 23 12:26:29.492185 2014] [autoindex:error] [pid 28679] [client 127.0.0.
    1:51815] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIn
    dex (index.html) found, and server-generated directory index forbidden by Option
    s directive

    I’ve tried configuring the hosts, and network files as well with no luck.

  • Nothing that sticks out no, I would post the output but it won’t let me. I’ve also tried configuring the hosts and network file to no avail. There’s definitely some disconnect somewhere.

  • Okay I got it!

    Seems like it was a combo of adding my server name in the hosts file and allowing port 80 in iptables.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

This question was answered by @KJax50:

Okay I got it!

Seems like it was a combo of adding my server name in the hosts file and allowing port 80 in iptables.

You can see the comment here.

Submit an Answer