Question

How do I set up my domain for being visible in everypage of my droplet

Hey there,

I followed this tutorial (https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean) to setup my domain in a droplet I have previously configured.

I had my domain (hopsfully.com) registered on DreamHost and if I enter my webpage that way, I can access the index of my droplet without any problem. The issue is when I try to click a link a post and instead of showing something like this:

http://www.hopsfully.com/?p=14

It shows this:

http://104.236.56.173/?p=14

I don’t know what I’m doing wrong so any help is really appreciated. Thanks.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi!

Log in to your WordPress admin dashboard and navigate to Settings -> General. You should see two fields named “WordPress address (URL)” and “Site address (URL)”. Edit them replacing your droplet’s IP address (104.236.56.173) with your domain name (www.hopsfully.com).

That should fix it :)