How to access,upload and download files on droplet

  • Posted November 15, 2014

i have created a droplet, In access droplet i get just option of “Console Access” on my browser. But how do i upload, download or edit files or directories on my ubuntu server?

i tried connecting this through my filezilla using my ip as host and root credentials. i’m unable to connect. i get error as : Connection attempt failed with “ECONNREFUSED - Connection refused by server”.

how do i connect.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

In filezilla login using sftp. Also, enter your correct port number, if you’ve changed it to some other value from 22. After that you’ll be able to upload, download and manage your files.

I found I had to complete the initial server set up tutorial, even though I used a one-click install. Once I was able to login to root with Putty (any ssh tool), it asks to reset the password in the shell. If you haven’t reset the password in the shell, you won’t be able to login with an ftp/sftp client. After I reset the password, I logged in with root and the new password with Filezilla. Unfortunately, it puts you in the user directory, not the top directory. You have to use the dropdown that lets you choose the directory in your ftp client. In Filezilla, it’s on the right and is called “Remote Site:” To find the site files, I had to then browse to /var/www/html

I have the same issue. I cannot make anything related to ssh work. When I tried to install vsFTP, it just hung up the service and I had to reboot/restore the Droplet to make it work. This should be a simple operation and it has taken me 3-4 days to try to resolve this with DO support, to no avail. This is taking wy too long to deal with and no way to speak with someone on the phone. Not good.

@alaukikk we’ve made a tool with a dedicated deployment action to DigitalOcean that lets you upload files on every push to branch:

All you need to do is enter the details to your droplet. The deploy is based on changesets which means only changed files are deployed. Here’s how it works:

I am also having these issues setting up an vsftp server on the backend, and getting FileZilla to connect with an SSH key.

What seems to be the normal on here is running through the tutorials, step by step, to be met with some seemingly small task, which leads into a whirlwind of further reading, down a rabbit hole of getting no-where.

What can be setup easily and running fine on a home brew server, seems to differ on a Virtual Host.

WHAT am I missing as far as getting a proper key into FileZilla and putting that key into the sshd service on the server for my FTP access to work!?

All this and I suspect theres an ‘Enable FTP’ option hidden somewhere within my Droplet settings… hmmmmmmmmm

Hello! I am trying to download my files via FilaZilla File → Site Manager; Click on the New Site button; Insert your server’s data (Host = IP; you can leave the Port blank if you’re using the default one) and choose SFTP - SSH File Transfer Protocol as used Protocol; Choose Normal or Ask for password as Logon Type, then insert your username (root by default) and your password; Save your configuration using the OK button. Every time i try to connect an error appears (Error: Received unexpected end-of-file from SFTP server Error: Could not connect to server) I reset my password and i have the same problem again! What i am doing wrong?

I could connect to my droplet using transmit on mac. I used SFTP In server field I used my server IP In username I used my server user name In password, I clicked the KEY Icon and selected my SSH Private key and then I press connect and i connected instantly and then I could upload any file I wanted :)

I hope this helps. :)

This comment has been deleted

Hi, I’m having the same problem… I created my first droplet, didn’t get any email. And have no idea how to access it?

No details sent to me about it in email.

You’re currently trying to access your server via FTP which is most likely not working as your VPS does not have this configured.

To begin you’ll want to download a terminal application such as PuTTY: When you first launched your droplet you most likely received an email with its IP address and default login details. Within PuTTY enter the IP address as the hostname and click Open. Then login using the details in the email (Username will be root).

Once you’re in you can use the below guide to install the desktop environment as well as a VNC server on the machine, once this is done you can access your VPS using any remote desktop software: