How to get NGINX and Wordpress customer permalinks to work...

Posted January 31, 2014 7.9k views
Hello, Does anyone know how to get NGINX and Wordpress customer permalinks to work?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

12 answers
If your owner:group and permissions settings are set correctly, WordPress should set permalinks automatically.
The default permalinks work fine, it is when set it to custom structure i.e.

From the WordPress Dashboard, go to Settings => Permalinks. Do you have Custom Structure selected? What value have you set?
Yes custom structure is set to /
It's not enough to have: /. You need to use a Structure Tag | WordPress Codex.
ahh ok. So i just tried /%postname%/

But i still get a 404 not found ?
Have you tried restarting Nginx?
Can you pastebin your nginx virtualhost config?
Yup still doesnt work
@Kamal, Im not sure what that is?
Did you follow a guide on install wordpress? If so, can you link it?
I have the same problem here. Using the structure, say, example below


sent me to 404 error.

I use Webuzo as my panel.
Submit an Answer