How to get to work Dashboard and Helm in DO K8s cluster?

Hello. I’ve created new k8s cluster with DigitalOcean. And there are few things I cannot figure out how to solve:

  1. kubectl shows that Dashboard pod is deployed, its service is ready to serve. With kubeclt proxy I managed to try to load dashboard via browser:
Error: 'dial tcp i/o timeout'
Trying to reach: ''
  1. With helm init I tried to install helm to cluster. And after that I can see that tiller-deploy pod is running. But with helm version I’ve got errror:
Client: &version.Version{SemVer:"v2.11.0", GitCommit:"2e55dbe1fdb5fdb96b75ff144a339489417b146b", GitTreeState:"clean"}
Error: forwarding ports: error upgrading connection: error dialing backend: dial tcp connect: no route to host

Same error with helm install stable/nginx-ingress

Looks like in both cases I cannot connect to cluster private network IPs. Any ideas how to solve it? Thanks in advance.

Show comments

Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Michael Guerin
DigitalOcean Employee
DigitalOcean Employee badge
October 3, 2018
Accepted Answer

Hey there,

It looks like you (and the others reporting the issue in the comments) may have ran into an issue with the Kubernetes master node not being properly assigned to your private network.

We’re working to resolve this now.

Had the same kind of issue twice tonight, deploying traefik in Kubernetes NYC

Just discovered: deleting k8s cluster will not delete your load balancers that were made when type=LoadBalancer services were deployed. I don’t know if it’s a bug or feature :) Digitalocean-cloud-controller-manager usually deletes load balancer right after you delete deployed service.