I am not able to start my nginx server , i get error first it worked but after reload it's not working

  • Posted April 21, 2020
  • LEMP

I am using ubuntu 18.04 lts

I followed the lemp guide and did everything write and next i am trying to install mybb , so i had to install php and then when i gave the command reload it worked but i get error not able to start a high performance server


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @monkeyluffy,

It would seem there is an issue with your Nginx, it might be from a simple typing error to something else in Nginx. Luckily, all of this can be tracked down from the Nginx error log.

In order to do that, you’ll need to follow these steps

  1. Open two SSH connections to your droplet
ssh root@YourDropletIP

2.Once you have the connections, in the first one run

tail -f /var/log/nginx/error.log

This will follow your log for any errors. Now that you are following the log in your second window type in

systemctl restart nginx

Once it fails, open back your first window. The error will be presented there.

From there you should be able to move forward with the experienced error.

If you are uncertain how to proceed, paste the error here, I’ll be more than happy to pinpoint the exact issue.

Regards, KDSys