I cannot acces my server, neither from command prompt nor from the web.

September 3, 2018 380 views
Apache Ubuntu 18.04

Hello, i´ve tried to change my webserver from nginx to apache and suddenly after i tried to install apache, i lost the connectivity to my server and i have no acess. It is like the server is offline, but the DO backend shows, that it should be online. I restartet it twice, but that doesn´t make any difference.

I am using putty and can access the server via console in the DO-backend

I don´t know what happened maybe someone has an idea?

2 Answers

Hey friend,

There are a few layers this could happening at. The first thing you want to do is ping the droplet IP to see if it responds. If it does not (under average conditions, avoiding mention of all possible exceptions), then your droplet most likely has no network connectivity. This means that something changed on the droplet that caused it’s networking to fail. There is no one correct path to resolving that, it has to be found where it occurred. It could be anything from the flip of a default firewall chain policy to a broken configuration. A few of us put this together not too long ago:

https://www.digitalocean.com/community/questions/having-trouble-with-the-network-on-your-droplet

If it doesn’t get you anywhere, feel free to open a ticket with our support team. There is likely more information here than simply removing Nginx and Apache if that is the case, and it may be important for you to give more details about what steps you took to install Nginx and then what steps you took to replace it with Apache. If you used any installer scripts, pasted commands from a tutorial, etc.

Jarland

Hey, thanks for the response, everything is working again now. I did use a command from a tutorial which caused the problem. Thanks for the answer!

Have another answer? Share your knowledge.