Question

I didn't get the proper SSL setup while installing Wordpress in a New Droplet

Posted July 5, 2020 203 views
ApacheWordPressLet's Encrypt

I am trying to setup a wordpress and want to use the Let’s Encrypt SSL, but in the first step while installing the Wordpress I got the option of installing the SSL and I did that, but then I deleted the droplet and tried again, but this time I am only getting the option of Installing the Let’s Encrypt SSL, and after that it shows another option of redirecting the non https to https, but I am not getting this option second time.

I thought they system installed the SSL certificate automatically this time, but I checked in my wordpress dashboard that there is not SSL certificate is installed.

I tried by deleting the droplet and started from the beginning 5-10 times, and each time it surpasses the option of redirecting the non https to https, and it doesn’t install SSL certificate at all.

What should I do NOW? There is no solution I can found over the internet, is there anyone expert who can help me?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi @Rohitk,

It seems you are using the WordPress Marketplace image, is that correct?

I’ve just tried to re-create the process to see if I would experience the same thing as you have. It seems that when you enter a domain/subdomain that doesn’t actually point to your Droplet, the scenario happens.

Basically, when you don’t have your domain pointed to the server, Let’s Encrypt can’t be installed and configured on the server. How Let’s Encrypt works is, it checks if the domain loads from the same server the request for an SSL certificate comes and authorizes it. If it can’t authorize it, then it doesn’t install the certificate. If there is no certificate in place, no http to https redirection is possible and thus having the step skipped.

Regards,
KFSys

In the first two or three times, I got the option of redirecting the non HTTPS to HTTPS, but after that it doesn’t come, and as you said like the domain is not point to your droplet.

I setup the site with WordPress and login to my WordPress Dashborad and installed a plugin called Really Simple SSl, and it shows that there is no SSL certificate is installed.

I tried again, but it skips the two steps of Let’s Encrypt SSL configuration while installing the WordPress. Is there any live support from Digital Ocean?

Submit an Answer