iredmail not sending or receiving

April 22, 2014 4.1k views
It says it sent the emails and their in the sent box from the web interface. I dose not receive mail went sent from back to Also wont receive from gmail. Any where I can begin to troubleshoot.
1 comment
  • I've been tailing /var/log/iredapd.log and all it tells me is:

    2014-09-03 06:54:47 INFO [] ->, DUNNO

    where is a real email address (created via Iredadmin) and is a working email.

    Note that all the virtual hosts have MX records.

    From the documentation shared, one bit that didn't work right away was setting "your first virtual domain name". The print screen stats that the hostname cannot be used!!!!!! (if you do it 2 times it lets up pass).
    For my 2nd attempt (different node), I've used a different domain with the same results.

    Any thoughts?

2 Answers
Have you correctly set up a MX record and TXT record (for your dkim key) for the domain?

If you haven't seen it already, you might want to check out this tutorial:
by Bulat Khamitov
If you would like to create your own online e-mail system, you can use iRedMail. In this article we will explain how you can do it on your Ubuntu 12.04 virtual server.
The mail log would be a good place to start looking, assuming that is where errors are being logged. The name will probably vary depending on distribution and whose installer you use, but most such logs end up in /var/log/. Running tail -f on the log and watching what gets logged as you try to send a message can be very helpful when troubleshooting such problems because even if there aren't any errors, you can track the progress of the process and see where to start looking.
Have another answer? Share your knowledge.