Question

Not able to use Cloudflare in Full (strict) or Full

Using WordPress installation with Cloudflare, when i make SSL/TLS encryption mode to Full (strict) or Full the website wont load it will show 521 error. Can you someone tell the steps to setup cloudflare fully with digital ocean, I wish to set the Cloudflare SSL/TLS encryption to Full.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @VishnuSivadas

Could you please let me know if you’ve already installed a SSL Certificate for your domain/site? I believe the strict mode needs to be enabled when the site it’s working properly over https.

You can check these tutorials in order to install a SSL certificate:

https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-20-04

https://www.digitalocean.com/community/tutorials/how-to-install-an-ssl-certificate-from-a-commercial-certificate-authority

Hope that this helps! Regards, Alex