Morning,

I have read just about all of the tutorials and other questions in my search for help but none seem to do the trick.

I have set up a droplet and then created 2 virtual hosts, on one of my virtual hosts I have set up a bog standard HTML form with the requirement of having the content sent to me via the PHP mail function, however depsite trying a number of suggestions from other posts, nothing appears to be working and no e-mails are being sent by the server following submission of the form.

Droplet is Ubuntu 14.04, unsure what other pertinent information to supply.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello dear @daveoldacre, a quick way to check the error messages being to prepend the following lines to your problematic .php script:

error_reporting(E_ALL);
ini_set('display_errors', 1);

It may give you more clues as to what is the actual problem to debug.

If you find yourself stuck at debugging, please share the errors you get and I will personally help you debug so you can enjoy your droplet in full again.

Cheers!