Question

phpmyadmin just vanished!

Posted August 12, 2019 430 views
PHP DigitalOcean Let's Encrypt

My phpmyadmin has just completely disappeared!

linkorchard.com - a wordpress site WHOOSH can’t make the connection!
namedream.com - a php site - can’t connect to database! WHOOSH!

All the phpmyadmin databases were in one location.

Have I been hacked?

I OFFERING CASH NOW TO HELP ME FIX THIS ISSUE ONCE AND FOR ALL PLEASE EMAIL DOMAINER111 AT GMAIL

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

7 answers

Hi there @domainer111,

Both the sites appear to be working fine for me.
This may have been a restart of your database or similar?

Are you still experiencing issues?
- Matt.

Hello @domainer111 ,

linkorchard.com - database connection error
namedream.com - flagged as not secure by chrome, but still accessible

phpmyadmin is just a gui tool for your database. Try accessing your database via terminal.

Thanks for helping!

@MattIPv4 :: I think you are on to something here. Because sometimes when I visit the sites, like now - they are fine.

But then I check again, and they are broken.

About a year ago, my ubuntu server was going down like clockwork a lot, sometimes several times a say, and at least once every other day.

So I paid someone to write me a cron job that searches for updates and reboots the server. The cron run every 17 minutes which could be a problem.

I am very uneasy with digitalocean because there is no way I should need an update every hour or so, previously there was very little update issues.

Do you have any solution for the database?

I note that the phpmyadmin runs on the ip which is not SSL. So I think this is part of it.

@bontokiz thanks for responding. These are the errors I get. Are you getting these errors now?

Alan

This is probably happening because your MySQL goes down, just check with /etc/init.d/mysql status

If that’s the case, and probably is, you just have to upgrade the server with more RAM or add SWAP memory like I do to my customers.

If you add a 1GB SWAP it will be fine, I usually set the SWAP with 2Gb regardless the amount of server RAM.

@fatorbinario Thanks for responding. I got it fixed, and the fixer said exactly the same thing - memory!

Could you tell me how I add a 1GB Swap?

I will check inside the account at DO.

Hi @fatorbinario thank you again - I resized the droplet to 2GB. Could I ask you – how do you check if the memory is a problem?

Best regards,

Alan

Yep.

free -m

fallocate -l 2G /swapfile

chmod 600 /swapfile

mkswap /swapfile

swapon /swapfile

free -m

Submit an Answer