Piwik 2.8.3 and php 5.3.3 not recognized

Posted November 10, 2014 1.8k views

I started to install the last piwik (2.8.3) behind a domain on my droplet but got problem to finish it. I have this in red ’ Erreur: Version PHP > 5.3.3 requis’ and so, i can’t keep on install this version.

So, looks like piwik doesn’t see the version of php required is installed.

Does anybody else saw this bug?
Any idea?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer


I looks like this was caused by a bug in the Piwik version check code. It was just fixed six days ago and will be in the next Piwik release. To work around the problem temporarily, edit the file piwik/core/testMinimumPhpVersion.php and change

$piwik_minimumPHPVersion = '5.3.3';


$piwik_minimumPHPVersion = '5.3.2';

h/t to