Question

Ports.conf change

Hello Every time I run “sudo certbot renew --dry-run” my ports.conf file changes. It looks as shown below. How do I avoid this?

If you just change the port or add more ports here, you will likely also

have to change the VirtualHost statement in

/etc/apache2/sites-enabled/000-default.conf

Listen 8080

<IfModule ssl_module> Listen 444 </IfModule>

<IfModule mod_gnutls.c> Listen 444 </IfModule>

vim: syntax = apache ts = 4 sw = 4 sts = 4 sr noet

Listen 80


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @adminjrfer,

I’m not sure what does it change as the formatting is a bit off and I’m not sure what would be the correct look however If your Apache is listening on port 80 and 443 it’s fine.

If your CertBot is changing the ports from 80 to 8080 or something else, what you need to do is open the /etc/letsencrypt/renewal/YourDomain.conf

and in there in the renewalparams change the installer from Nginx to Apache:

# Options used in the renewal process                                                   [renewalparams]
authenticator = apache
installer = apache
server = https://acme-v02.api.letsencrypt.org/directory