Prestashop display blank page after installation but back office run well

August 16, 2015 2.2k views
Server Optimization DigitalOcean Ubuntu

Dear all,

Could you help me to investigate why my prestashop display blank page but in back office it can run normally.

my web : http://arumnusantara.com

What kind of setting should I take? I have increase memory limit but still the same. I think the configuration is fine. I follow http://blobmarket.com/blog/en/securing-prestashop-1-6-on-a-digital-ocean-vps.html

I use virtualhost. I have use it for wordpress hosting

Please help.
Thanks and regards,

1 comment
2 Answers

Hi Ardian,

You should check the PHP error log to find out what the actual error is. Without knowing the actual error, you'll just be taking guesses about things like whether it's a memory limit issue.

For example, if your server is managed by ServerPilot, the PHP error log would be at:


Dear jsamuel,

THanks for your reply. I have checked my PHP error log. I see 2 error related to prestashop. Here maybe you could help me. After that, there is no error until now. When I access front office just now, there is no error in error log but still blank page (only display logo)

[Sun Aug 16 22:01:40.162503 2015] [:error] [pid 1462] [client] script '/var/www/arumnusantara.com/publichtml/install-dev/sandbox/anything.php' not found or unable to stat, referer: http://arumnusantara.com/install-dev/index.php
[Sun Aug 16 22:09:18.091076 2015] [:error] [pid 1391] [client] PHP Fatal error: Uncaught --> Smarty: Unable to load template file 'helpers/kpi/kpi.tpl' <-- \n thrown in /var/www/arumnusantara.com/public
html/tools/smarty/sysplugins/smartyinternaltemplatebase.php on line 129, referer: http://arumnusantara.com/admin-dev/index.php?controller=AdminDashboard&token=95afe26b924621b9577ec6585ce9088d

Have another answer? Share your knowledge.