Hi ,
I try every thing for rdp connection . But ı still can not accses my vps server . I can show my vps server on the command promt .But When I want to connect with RDP it give fail report.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @azadavsar,

Have you installed a desktop environment on your server? Also in order to connect via RDP you would need to have a service like xRDP installed as well.

What I could suggest is giving X2Go a try, here is a step by step tutorial on How To Set Up a Remote Desktop with X2Go on Ubuntu 20.04:

https://www.digitalocean.com/community/tutorials/how-to-set-up-a-remote-desktop-with-x2go-on-ubuntu-20-04

Regards,
Bobby

by Alexandru Andrei
X2Go provides a working "cloud desktop," complete with all the advantages of an always-online, remotely-accessible, easily-scalable computing system with a very fast network. It is also more responsive and more secure than many VNC solutions. In this tutorial, you'll use X2Go to create a Debian 10 XFCE desktop environment that you can access remotely. This "cloud desktop" will include the exact same utilities that you would obtain had you installed Ubuntu 20.04 and XFCE on your local machine.
  • hi , ı have a destktop environment on my server . I have xrdp FOR ubuntu 18.04 I read this documant and ı did every thing . But it still doesn’t work

    • Hello,

      I would recommend checking the following:

      • Make sure that the xRDP service is running
      • Check the xRDP log for some more information
      • Make sure that the service is listening on port 0.0.0.0:3389, you can check that with the netstat -plant command
      • Make sure that port 3389 is open for incoming TCP connections

      Regards,
      Bobby

      • thank you for your comment. when I opened port I could connect to rdp. But now ı take this, xrdp login failed for display 0 . Do you have any idea ?

        • Hi there,

          I could suggest a couple of things:

          • Add a new low privileged user
          • Make sure that the username does not start with a number and that it is lower cases only
          • Set a password for the user
          • Try connecting with that user

          Let me know how it goes!
          Regards,
          Bobby

Submit an Answer