Redmine Subdomain

August 4, 2013 4.3k views
I have created a redmine droplet and setup a A Name Record in my DNS to point to the server. When Accessing the server by the IP the redmine is show, but when trying to access it threw the Subdomain a page saying it's being installed is shown. Any help on how to make it display properly would be great. I am not great with setting up servers so please give details on default location of config files in your response since I won't know why they are at.
13 Answers
I would like to add it's the Redmine Dropelet with Default settings. I didn't install Redmine myself.
You have to use the subdomain as your droplet's hostname, please see

So instead of it would be
Please note that you cannot rename your droplet as that won't fix it. You can either edit /etc/apache2/sites-enabled/yourdropletshostname or destroy and recreate your droplet.
When the droplet was created I did use the host name of
What's the output of this command?

curl -F 'sprunge=
I have the same issue - the site works fine at the IP but not at the domain name. The domain is - I used the one click installer and had my hostname set up correctly.

Vhosts looks correct


DocumentRoot /home/redmine/redmine/public

RailsBaseURI /public

Options Indexes MultiViews

AllowOverride None

Order allow,deny

allow from all



Did you restart apache? service apache2 restart
Yes I have restarted apache and have rebooted the server. Any ideas?
I tried visiting and the redmine login prompt popped out - are you still experiencing this issue?
I force refreshed and I can see it now - thanks for the help.
If anyone else experiencing an issue with the "Redmine Installing ... "

1. Make sure you have an A Record pointing to your Droplets IP address
2. Copy your vhost for your droplet URL from `/etc/apache2/sites-enabled` to httpd.conf located `/etc/apache2/httpd.conf`
I am having the exact same issue and couldn't get it working! The IP works fine but subdomain doesn't work. subdomain is pointing the same IP address. Any clue?
Have another answer? Share your knowledge.