Server response very slow

Since a few days my server response is very slow, when i access my web app from browser but also when i use command line there is lag and delay to write commands. What could be the problem ?

I tried upgrade from a 1G / 1CPU to 4G / 2CPU hoping it would solve it but its same. basically i run 3 instances of a nodejs webapp, use pm2 and nginx, nothing special, 26G free disk space.


Uhave to use the best sever with a hacker to be a best person and take the right decision to be safe from ur problem

I also often get this error in Chrome console, don’t know if related of just because of the long delay: net::ERR_SPDY_PING_FAILED 200

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

If the performance is the same after upgrading it might be your internet connection or one of the internet routes you travel on from your workstation to the DigitalOcean datacenter where your droplet is located.

I would do a few things now:

  1. Check the graphs for your droplet - is there anything out of the ordinary in terms of Network or CPU consumption? If the graphs are all low then it’s probably not the droplet.

  2. The net::ERR_SPDY_PING_FAILED 200 might be related, it looks like an older feature of Chrome browser. Have you tried restarting / updating chrome lately? If you google that error there are a few recent posts on the net that describe some different troubleshooting steps if updating doesn’t help.

  3. If that doesn’t seem to help, some other suggestions involved flushing the local DNS cache on your computer.

  4. Ask co-workers or friends to check your site and see if it is also slow to them - or try yourself from a different device and internet connection.

Good luck and let us know how it is going… feel free to ask more questions as you run into them.

Hello, Thanks a lot for the answer.

My Chrome version is the last and i have same behavior with Firefox.

Here the graph related to my droplet:

Just tried ipconfig /flushdns but didn’t change anything

I’ll keep searching then, any other idea welcome :)