Question

server return 504 when uploading file

I’m using multer to upload the file on the server that is working perfectly on the localhost and as soon as i deploy it to digital ocean droplet and when I hit the upload-file endpoint it waits for around 30 seconds then returns 504 bad gateway.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi @appeffie,

It sounds there could be two things related to this issue. The first thing that popped in my mind while reading your question was the max execution time being hit.

Additionally, what other it could be is some issue with Nginx itself which is being hit on certain condtions.

Luckily, since you are getting 504 Bad Gateway both errors should be logged in your Nginx error_log. I would recommend checking your error logs like so

tail -f /var/log/nginx/error.log

Once you’ve executed the command, try to re-upload the file. The error should be logged in as soon as you see the error on your website.

As soon as you see the error, you can post it here and we’ll be able to provide you with more information how to proceed.

Regards, KDSys

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.