Setting up HostPapa Advanced Email

October 26, 2014 2.7k views

I've have hostpapa advanced email, and to use it I need to change the domain's MX record and CNAME record to point to my advanced email.

Hostpapa provides this information(see link below), however I'm unsure how to set it up, I tried to follow a few examples I've found online however I've had no such luck on getting it to work.

If anyone could help me out on this issue it would be much appreciated as I'm completely lost.

  • So what is not working? The tutorial seems pretty straightforward.

  • I'm unsure on how to enter this on my digitalocean records. I don't have a cpanel with hostpapa, and they told me I need to change this here on digitalocean

  • You should really try to give some more information. The reason you are not getting any help right now is because you make it way too hard to help you. Which domain are we talking about? Where does this server live? What do you really want to do?

  • Sorry, I'll try to explain my issue better.

    I created a site on hostpapa a month or so ago. I realized that they couldn't provide me with what I needed in a hosting plan. So I then transferred my site over to digitalocean. It's now up and running -

    Since I've moved my site to digitalocean I no longer needed my hosting plan with hostpapa, however my domain name is still with them. When I canceled my hosting plan with hostpapa, they also took away my email accounts I had with them, as it was part of the package. So I went ahead and ordered hostpapas advanced email. The email account can only send emails, it's not receiving them. Hostpapa told me that I needed to change my MX record and CNAME record at digitalocean to point to my advanced email. they provided me with the link in my question to help with this, however I don't have a cpanel here with digital ocean of course.

    As far as I understand I need to log into my digitalocean account, go into the DNS settings and add new records, MX and CNAME.

    I added a MX record (not sure if I did it right) - where it saids enter hostname i entered
    and for enter priority I entered in 0

    I'm not sure if that's right or not-
    Then for cname it asks for "enter name" and "enter host name" I'm unsure on what to enter into these fields. or if this is even the right way of doing what needs to be done.

    Sorry, as you can tell I'm new to all of this. Thanks again for the help.

1 Answer
;   IN  MX

;; ANSWER SECTION: 1800 IN    MX  0 1800 IN    MX  0

As you can see you broke your email because you have configured as one of your MX records. You don't have anything listening on port 25 on that domain. Remove it. Also, this is not how you use priorities. Read this at your leisure.

  • Thanks for the help, however I'm still completely lost as I don't know how to do that.

Have another answer? Share your knowledge.