ubuntu 16.04 self-signed cert versus let's encrypt error

Hey There,

I have looked all over the interwebs for the answer to this, and can’t find one, so if this is redundant, I am sorry:

I installed ubuntu 16.04 on my Droplet, and put in the LAMP stack. I manage a wordpress site, so I added that. Wordpress only works with https, so I needed a certificate for the site.

I first used the tutorial here, and it worked, I guess, except that there were huge warnings all over Chrome and Safari that the site wasn’t safe!!, so I realized I needed an external CA, so I used this tutorial here. Man was that easy, except…

At this point I was getting the err_connection_refused and failure on load for the browsers, and I determined that it was an error relating to the two certificates. So I followed this, and part of that answer was to go back through the self-signed tutorial backwards. I disabled OpenSSH in the firewall, and enabled it, and tried several things, so now I think I’ve screwed myself and it is so all over the place that I will have to start over at the stack install to correct it.

So my question is this:

Is there a way to remove all traces of SSH protocols to start over at bare encryption again, or do I have to do a clean install, again.

I am out of ideas on how to fix this, and admittedly am not a network admin, so I am sure I simply messed something up, including not providing enough info here for proper answers from the forum, but I could really use some answers, otherwise it is back to square one tomorrow.

Thanks for allowing me this desperate moment.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi @wscotgrey

You went the long way, I would say, but let’s see if we can get you back :-)

I don’t see why Apache certificates should have anything to do with SSH, but I’m guessing that’s just a typo and you meant SSL.

It would probably be easier if you paste the Apache vhost configuration for your site. Once we’ve cleaned up the configuration, then it should be fairly easy to follow the Let’s Encrypt tutorial, which you already followed with ease.

Your vhost configuration file(s) is located in /etc/apache2/sites-enabled/


New reply as the previous was maxed :-).

Have you changed your WordPress URL to use https instead of http? If not, we need to do that now.

If not, open up your wp-config.php file and find define('WP_DEBUG', false);, then directly below it, add the following (change to your domain).


Save the file and try accessing your site again, or upload the file back (if you didn’t modify it from the CLI).

Also, if that one file, default-ssl.conf, still exists, delete it and restart Apache.

This comment has been deleted

    Try DigitalOcean for free

    Click below to sign up and get $200 of credit to try our products over 60 days!

    Sign up

    Featured on Community

    Get our biweekly newsletter

    Sign up for Infrastructure as a Newsletter.

    Hollie's Hub for Good

    Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

    Become a contributor

    Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

    Welcome to the developer cloud

    DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

    Learn more
    DigitalOcean Cloud Control Panel