Question

Ugrade from PHP Version 5.3.10 to PHP Version 5.4 or higher

  • Posted August 20, 2013

Hello

Just install LAMP 12.04 LTS and I would like to upgrade the PHP version of the LAMP droplet. Can someone help?

I tried with this tutorial but not working at DigitalOcean Ubuntu srevers. http://askubuntu.com/questions/109404/how-do-i-install-latest-php-in-supported-ubuntu-versions-like-5-4-x-in-ubuntu-1

Regards Jacques

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@Pablo: That is for CentOS. <br> <br>You should use ondrej’s repo: http://askubuntu.com/a/109544 <br> <br>What part isn’t working?

I think it happens because apache get updated to 2.4 when installing php 5.4+ there are some changes in the configuration between the apache2.2 and 2.4 :)

Hi. I upgraded from php 5.3 to 5.4 and 5.5 using the steps in the link (Ubuntu 12.04). The virtual hosts stop working, all the domains point back to /var/www instead of their corresponding location. So I had to restore my snapshot back to 5.3.

Yes, I know. Have you tried it? It should work perfectly. Do you get any errors?

Hello <br> <br>Your link (http://askubuntu.com/a/109544 ) you are sharing is the exact same link I was trying as well. <br> <br>Regards <br>Jacques <br> <br>

Check out <a href=“https://www.digitalocean.com/community/questions/how-to-update-php-to-v5-4-or-v5-5-on-centos-droplet”>How to update PHP to v5.4 or v5.5 on CentOS droplet?</a>.