Question

Unable to locate libssh2 package

Posted August 10, 2018 6.8k views
ApplicationsUbuntu 18.04

I was following this tutorial https://www.digitalocean.com/community/tutorials/how-to-configure-secure-updates-and-installations-in-wordpress-on-ubuntu

and I tried installing libssh2-1 package using the following command

 sudo apt install libssh2–1-dev libssh2–1

and I got an error message

E: Unable to locate package libssh2–1-dev
E: Unable to locate package libssh2–1

Now it is my understanding that these packages are part of default Ubuntu installation so why are these packages missing? What should I do? I already tried apt update command but it doesn’t help.

2 comments
  • You’re following a deprecated tutorial. What’s your Ubuntu version?

  • I am using Ubuntu 18.04 and I do realize that the tutorial is outdated.

    I do know that. But until then all commands are same for both old and newer Ubuntu versions. Also as far as I checked, libssh2-1 package is available under Ubuntu 18.04.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

@nspeaks

sudo apt install libssh-4 libssh-dev

Hope this helps.

Submit an Answer