vsftpd, installed correctly, server user isn't able to login

Posted August 17, 2014 1.4k views

I followed the vsftpd setup for CentOS 6 and everything went fine. But when trying to login via sftp it just keeps asking for the user/password. I’ve tried the root user, tried my regular user. Neither of them will work and get me into the server.

Any idea what’s going on, did that guide I followed leave something out or what?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

How are you accessing the server? Using a GUI client? Have you seen this tutorial: How To Set Up vsftpd on CentOS 6

If you already can access the server via SSH, then SFTP will probably be a better option:

by Justin Ellingwood
SFTP is a secure way to transfer files between local and remote servers. Much more secure than FTP, this protocol uses an SSH tunnel to establish a connection and uses encryption to transfer files in an interactive session.