Question

Wordpress Admin page gives 500 error

I set up a wordpress droplet and migrated an existing wordpress e-commerce site to it.

Currently accessing the site with IP address until I am ready to migrate my domain to it.

I created a self-signed SSL certificate to access the portions of the site that force SSL (admin page, checkout, my account etc.)

Got everything working properly except for the admin page. The other HTTPS pages load fine and I can even log into my admin account on the my account page within Wordpress, but when I click a link to the admin dashboard or navigate to /wp-admin/ it causes a 500 error.

I have changed all the settings in wordpress and wp-config to point to the IP rather than the domain and have checked permissions of the wp-admin folder as well as directory settings of the virtual hosts, everything appears to be fine.

Any suggestions?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Can you visit the wp-admin page and then go and run this command and post the error log here, since 500 means something internally went wrong in Apache, but the error log contains the details. You can replace your domain with domain.com if you feel like it - and IP address with 1.2.3.4

tail -50 /var/log/apache/error.log

In case you’re using Nginx instead of Apache, run this:

tail -50 /var/log/nginx/error.log