Question

WordPress - certbot installation create permalink issue

I try to install WordPress on Ubuntu 20.04 with a LAMP stack as the following tutorial https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-on-ubuntu-20-04-with-a-lamp-stack with exact step by step, but when I go to WordPress Dashboard > Setting > Permalink and change the default plain to the custom permalink, I got 404 pages with sample post and page. If I type HTTP instead of HTTPS, I saw posts and pages displayed as normal.

When I try to create a new post I got the error: “Updating or Publishing failed. The response is not a valid JSON response”.

I guess SSL certification makes the issue but don’t know what is the problem exactly and can’t find the solution on Google. Some post advice I should keep the plain permalink but It’s not good for SEO. Anyone has met this issue? I very much appreciate your response.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @nguyennamnvn9x,

It sounds to me like there are some issues loading the website over SSL, do you have an SSL installed or have the proper HTTPS Apache2 config?

To these those, it will be best to post the config here to see if we can find anything that might be a reason for this behavior.

Hello,

Can you share the contents of both your HTTP and HTTPS Apache Vhost files? It sounds like that something might not be right with your HTTPS virtual host.

Alternatively, if this is a fresh new website, I could suggest using this 1-Click WordPress installation:

https://marketplace.digitalocean.com/apps/wordpress

It also comes with an automated SSL installation out of the box.

Best,

Bobby