Question

WWW Website redirects to NOT Secure IP (while HTTPS works correctly)

I’ve installed Wordpress on Ubuntu Droplet, migrate my website and then add the Let’s Encrypt cert. If you browse the website using HTTPS everything works but when you access the website with www it redirects to the IP with a Warning of NOT Secure Website.

If then you click on Continue to the website it goes to the secure HTTPS.

I’ve installed Really Simple SSL plugin on Wordpress but still the same issue.

Any idea how to fix this?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @liukrossini,

This sounds being an issue with your Apache Vhost file. You’ll need to review it and make sure everything is actually configured properly.

If you are uncertain how to proceed in checking your Vhost file, I’ll recommend going over the following two tutorials :

https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04-quickstart

https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04

They should guide you through the process of creating a virtual host and you would be able to see the differences with yours. If you however still experience issues afterwards, you can post your vhost files here.

Regards, KDSys

Hey!

So I’ve followed the step by step guide for the Vhost but I still get the same error.

I managed to add the correct vhost configuration, then I tried to reinstall the SSL certificate but when I tried to redirect all the traffic to HTTPS I got an error
Even when I tried to do the Auto-Renewal test I got another error.

I really don’t understand the issue here… any help??