Question

404 error when pointing domain wordpress LiteSpeed Web Server

I am trying to set up my domain (DNS on CloudFlare) to point to a DigitalOcean droplet, but I can’t seem to get it to work properly. I have an Ubuntu Droplet, running WordPress, and on CloudFlare, I have configured an A record to point to the IP address of my droplet. When I try to access it, I get a 404 Error. But when try access using IP it is working normal.

domain http://meticonbikes.com/ IP 157.230.134.175

what should i Do?

thank you

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have the same problem. Did one click install from DO. Cannot change IP from WP General settings… does not accept Domain name.

Just a quick fix for me I navigated to projects-> project_attributes_I_want_to_alter Then under resources I proceed to click on the link of the domain I have listed, making sure I have the correct DNS pointing to all 3 options for digitalocean. After I access the new screen for the domain name there is a section called DNS records. If there isn’t a type A listed there then create one with parameters and values such as this: Type: A Hostname: your_domain_name

directs to

Value: droplet_IP(public not private) TTL(seconds): 3600 (this is a default setting)

After that if it still doesn’t work try running nmap outside of your ssh connection, so in a normal terminal, and run this:

nmap your_dropletIP

Press enter and check to see if the ports that should be open are. If I do so mine looks like this, also nmap version depends on your installation. Do not upgrade unless you absolutely need to:

Starting Nmap 7.80 ( https://nmap.org ) at 2019-08-13 12:08 EEST
Nmap scan report for your_dropletIP
Host is up (0.021s latency).
Not shown: 985 filtered ports
PORT     STATE  SERVICE
22/tcp   open   ssh
80/tcp   open   http
443/tcp  open   https
1720/tcp open   h323q931
6000/tcp closed X11
6001/tcp closed X11:1
6002/tcp closed X11:2
6003/tcp closed X11:3
6004/tcp closed X11:4
6005/tcp closed X11:5
6006/tcp closed X11:6
6007/tcp closed X11:7
6009/tcp closed X11:9
6025/tcp closed x11
6059/tcp closed X11:59

Nmap done: 1 IP address (1 host up) scanned in 4.18 seconds

If you notice my ports 22 - for ssh, 80 for http and 443 for https. If I access my page now I can see a working page and everything runs smoothly. If you have further issues you may have configuration problems and will have to run through the necessary logic and fixes for your setup. Otherwise I would try and email the email address associated with the droplet build you have created.

Friendly Regards, Complex

I’ve followed the above suggested solutions and while it’s not clear I found success by adding mydomain.com (use your domain obviously) to the Example virtual hosts set up. So the virtual host has the IP address and then the domain.

I’m new to server admin and this level of tech so I excuse this if is a dumb question but can I change the Example virtual host name or does this not matter?

My thinking is to create a new virtual host name mydomain.com and then copy the General tab settings from Example, so the vhost still points to /var/www/html for example.