Bandwidth around 6Mbits/sec?

April 9, 2016 398 views
Networking CentOS

When accessing my droplet from my home (Comcast) network I get a maximum of 6 megabits/second throughput, sometimes significantly less.

My home cable connection is 90 megabits/sec, verified using speedtest.net to several different servers NOT in Comcast's network.

When I run the speedtest.net cli tool on my droplet I get 120 Mbit/sec to local New York servers, confirming that Digital Ocean has a fast backbone connection.

When I run the speedtest.net tool from my droplet to the Comcast server in my area (server ID 1780) I get upload (droplet->client) speeds around 27 Mbit/sec, which isn't great but still 4-5 x faster than what I see end-to-end.

Traceroutes and pings in both directions look OK.

Is there a way to diagnose the very low bandwidth end-to-end?

2 Answers

We'd love to take a closer look - can you file a support ticket by either emailing contact@digitalocean.com, or https://cloud.digitalocean.com/support/suggestions


That certainly doesn't sound right. It seems like there's a routing issue somewhere between the Droplet and the Comcast network in your area.

Please open a support ticket, making sure to include traceroutes from the Droplet to your home IP address and the other way around so that the team can properly investigate the issue and see what's going on.


Have another answer? Share your knowledge.