Can someone assist me with installing powerdns?

I’ve went through every power dns install tutorial here all of which have ended in errors. Goal: install powerdns on 2 vps one for pvns1 one for pvns2 These nameservers need to be able to be used anywhere as a offshore nameserver.

Can someone help me out"? 23hrs in

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

I should add, I will be using whmcs plugin of solutedns to assign these.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I’ll do this. Thanks man, you know how it is. Get aggravated & ready to say f it. lol I was getting these commands from other forums by googling my error codes. I’ve also went back and redone stuff like this to have no errors the next time & it be something I a. overlooked b. entered wrong. I’ll update

Yes, that was my first shot. So with that I got it completely setup with power admin and all. Issue I had was with the DB. Requirements that’s not the word, basically what mysql depended on wasn’t compatible with the ubuntu version. Something had been nulled. So on to try to update ubuntu. It would not upgrade due to that. I researched a solution for this for a couple hours and it seemed like i was running 50 commands and possible installing a lot of un needed stuff as none of the ideas were working. So i killed it and attempted on centos 5. I got about 3/4 through that install & the directions were not real detailed. Said the mac address was not as expected. I couldn’t locate anything that was not talking about someone setting up a local dns server. So i destroyed this one and found what looked to be the solution. virtuozo or whatever install script. Got to step 3 i believe and upon entering the command provided returned command not found. Tried breaking it down into single commands, it took the commands but did not execute the install. The download did save to the vps but it wouldn’t execute. I checked the permissions and they were all right. wasn’t much research on this material on this one. I tried to do the same on centos 6. same result. I cussed my little dog out over here & had a smoke outside. :) lol

I apologize for not providing more details as I was confident in finding a solution on my own. Sadly that was not the case.

Hi @OffshoreHost

You say that every installation ended in error - can you supply those errors, since that will help us trying to figure it out. Also link to whatever tutorials, so we know what you’ve tried to follow.

I’m guessing you have already read and followed this tutorial?