Question

Can't connect via SSH by user@domain.tld but can via user@ip.ad.re.ss

I have a droplet set up with a LEMP stack and domain name. I can connect to the default Nginx page using the domain in a web browser. Nmap successfully scans the server and correctly resolves the domain to the IP address. Ping does not. I am able to connect via SSH using the IP address, however if I try using ssh user@domain.tld, it hangs for at least five minutes (I have not left it on longer).

I suspect the issue may have to do with my local firewall, however I am unsure.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It could be firewall, but could also be rDNS. Make sure to properly configure reverse DNS to prevent long delays when things try to look it up. Make sure that the hostname specified in the DO interface is correct, as it populates the rDNS entry accordingly.