Question

Can't seem to load fuse module

  • Posted May 25, 2014

Ok - what am I doing wrong? I’m using Debian 3.2.41 with the 3.2.0-4 kernel. I’ve installed fuse and even rebooted. When I try to load the fuse module, I get:

ERROR: could not insert ‘fuse’: Unknown symbol in module, or unknown parameter (see dmesg)

And dmesg shows: fuse: Unknown symbol nosteal_pipe_buf_ops (err 0)

Any thoughts?

Subscribe
Share

I’ve had this a couple of times, and its easy to fix (at least in debian 7 ( wheezy ) )

  1. log into the digital ocean control panel
  2. go to the droplet that has this issue.
  3. go to settings, then kernel
  4. change it to the latest kernel. i.e. for me its: * Debian 7.0 x64 vmlinuz-3.2.0-4-amd64 (3.2.60-1+deb7u3)
  5. power down your droplet
  6. power up.

then if you do modprobe fuse from the cmd line, there shouldnt be an error

I still have the problem, i updated the kernel, but no change. Got any advice?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I was able to solve that problem by matching the kernel package with the selected kernel from the Digital Ocean website NOT with “uname -a”, because uname will list the version information of the kernel in use (the selected kernel from the configuration menu). But the trouble is the fuse module that is used inside the virtual machine (by apt-get magic). <br> <br>You can get older kernel packages from http://snapshot.debian.org/ <br> <br>Good luck! <br>:-) <br>

FUSE is currently broken on Debian Squeeze (7.0 64bit) on digitalocean. After doing an apt-get update && apt-get dist-upgrade, the kernel was upgraded and modprobe fuse no longer works; <pre> ERROR: could not insert ‘fuse’: Unknown symbol in module, or unknown parameter (see dmesg) >> fuse: Unknown symbol nosteal_pipe_buf_ops (err 0) </pre> Kernel Info:

3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux

have rebooted and power cycled machine.

We use s3ql to mount google cloud storage for backups – so it’s a pretty big deal to have this broken w/ machines filling up their disk space.

Same problem here. Kernel 3.2.0-4-amd64 version 3.2.41-2+deb7u2. Running ‘dpkg-reconfigure fuse’ gives this output: <br> <br>udev active, skipping device node creation. <br>update-initramfs: deferring update (trigger activated) <br>Processing triggers for initramfs-tools … <br>update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64 <br> <br>Looks like fuse module is now in kernel, but… when I run ‘modprobe fuse’ (after reboot) I get this: “ERROR: could not insert ‘fuse’: Unknown symbol in module, or unknown parameter (see dmesg)” <br> <br>Did anyone solve this?

Try powering off your droplet (<code>sudo poweroff</code>) and the booting it up from the control panel.

Could you solve it?

uname -r shows: <br>3.2.0-4-amd64 <br> <br>droplet kernel in the control panel: <br>Debian 7.0 x64 vmlinuz-3.2.0-4-amd64 <br> <br>Looks the same to me.

Run <code>uname -r</code> and make sure the output matches your droplet’s kernel in our control panel.