Question

Cannot connect to Postfix on port 587

Posted January 30, 2020 2.9k views
Networking

Hi there,

I have installed Postfix on a droplet, and configured it to work on ports 25 and 587.

I’m unable to make a connection remotely.

If I do the following from the droplet itself:

> telnet localhost 587

I get a reply from Postfix.

However if from my either my local system or the droplet itself I do:

> telnet server.domain.com 587

I get:

Unable to connect to remote host: Connection refused

I have read that DigitalOcean often block ports 25 and 587 by default, but I have contacted support and been assured by multiple agents that they are not blocking those ports on our droplet.

Is there anything else I can try?

Thanks,

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello,

This sounds like that you might have a firewall on your Droplet. If this is the case you need to open port 587 for incoming and outgoing TCP connections, for example if you are using Ubuntu and if you have UFW enabled, you could open the 587 port with this command:

sudo ufw allow 587/tcp

Also, check the if Postfix is binding correctly on 0.0.0.0:

  • netstat -plant | grep 587

Output:

tcp        0      0 0.0.0.0:587     0.0.0.0:*               LISTEN      1161/postfix

Let me know how it goes!
Regards,
Bobby

  • Thanks for your reply, I should have mentioned that there isn’t a software firewall running.

    > ufw status
    
    Status: inactive
    

    Result of netstat returns:

    tcp        0      0 127.0.0.1:587           0.0.0.0:*               LISTEN      16010/master
    

    Is 127.0.0.1 incorrect?

    Thanks,

  • OK, your post gave me a clue.

    I edited /etc/postfix/main.cf and changed:

    inet_interfaces = localhost
    

    to

    inet_interfaces = all
    

    Which has fixed it!

    Thank you!

Submit an Answer