Question

Cannot get kubernetes Horizonal Pod Autoscaler or Metrics Server working

I am using the new hosted Kubernetes (which is pretty awesome, btw), however I cannot get HPA or Metrics to work at all.

I have deployed both heapster and metrics server just in case one was not supported, however on 1.11 I expect metrics server to work. At first, metrics server was not able to connect to the kubelet endpoint via dns (since the names don’t exist as DNS), so I reconfigured metrics-server to use these flags:

--kubelet-insecure-tls
--kubelet-preferred-address-types=InternalIP

This enabled the connection to kubelet and the errors are gone in the metrics server logs. Now I am seeing on the HPA:

unable to get metrics for resource cpu: unable to fetch metrics from resource metrics API: the server is currently
unable to handle the request (get pods.metrics.k8s.io)

This is where I get stuck currently. Any help is appreciated. Thanks!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This seems to be resolved in newer clusters that I have spun up. The aforementioned github issues point the way.

+1 - looking for a fix.