I can login with the ssh, but it doesnt seem to work if i try to use mongodb compass. I have authorization enabled and i login succesfully with SSH for mongodb. But it doesn’t work on mongodb compass. It says Connection Timedout.

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi there,

You can follow the steps on how to do that here:

https://www.digitalocean.com/community/tutorials/how-to-configure-remote-access-for-mongodb-on-ubuntu-20-04

It is step number 2 that you need to complete in order to change the MongoDB binding from localhost to the server IP.

Hope that this helps.
Best,
Bobby

by Mark Drake
This tutorial walks you through configuring a MongoDB installation to securely allow access from a trusted remote computer. This will involve updating your firewall rules to provide the remote server access to MongoDB's default port and changing Mongo's configuration file to update its IP binding setting.