Centos 7 - Warning: mysqli_connect(): (HY000/2002): Permission denied in

February 26, 2018 10.9k views
CentOS WordPress

Hello, you are having this error while trying to activate the plugin. Has anyone ever had this error?

Warning: mysqli_connect(): (HY000/2002): Permission denied in

thanks.

1 comment
  • Hi, i am having same problem but not in the suituation while activate the plugin,
    Acutually getting this warning while upgrading php from 3.5 to 3.9.25
    Also i have disabled selinux, but same result i am getting

1 Answer

Apache was not configured for external access.

Friends, the solution is:

sudo setsebool -P httpd_can_network_connect 1
Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!