Configuração dns no registro.BR e servidor

July 3, 2015 11.9k views
DNS

Pessoal, tenho um servidor na DO, no meu registro.br estou apontando o dominio para o ip da maquina e também estou apontando ns1.dominio e ns2.dominio, para esta máquina, mas quando tento em outro dominio colocar ele redirecionando para master : ns1.dominio e slave ns2.dominio, ele da erro:

Servidor DNS Master: Conexão recusada
Servidor DNS Slave 1: Conexão recusada

No meu servidor só tem o LAMP instalado e criei vhost para os 2 dominios.

Obrigado

14 comments
  • Amigo, conseguiu alguma resposta?
    Estou com o mesmo problema.

    Obrigado!

  • Ainda não, utilizei o dominio ns1.digitalocean.com e criei dns na minha conta para resolver meu problema.

  • Pra resolver meu problema eu fiz um redirecionamento de zonas no RegistroBR. Pra quando eu acessar meu dominio redirecionar para o ip da minha VPS.

    Funcionou! Mas não estou utilizando o dns da digital ocean. E estou tendo problemas para criar subdominios =/

  • eu aponto o domínio para a maquina e os subdomínios eu configuro com os vhosts do próprio apache.

  • Tenho o mesmo problema! =/

  • Consegui resolver o meu caso.
    Eu tinha criado o domínio no digitalocean com o nome do domínio errado.
    Exemplo:
    Eu tinha digitado: "www.dominio.com.br", só que no registro.br estava com o seguinte domínio: "dominio.com.br".
    Ai eu deletei o domínio criado anteriormente, criei um novo com o mesmo nome do que existe no resgistro.br e funcionou perfeitamente.

  • Eu coloquei o domínio mesmo da DO e depois dentro do sistema deles eu defini meus DNS

  • Faça como luizpaulo165 ( https://www.digitalocean.com/community/users/luizpaulo165 ) disse.

    Eu tinha criado o domínio no digitalocean com o nome do domínio errado.
    Exemplo:
    Eu tinha digitado: "www.dominio.com.br", só que no registro.br estava com o seguinte domínio: "dominio.com.br".
    Ai eu deletei o domínio criado anteriormente, criei um novo com o mesmo nome do que existe no resgistro.br e funcionou perfeitamente.

    nesse caso digitar o dominio sem www

    Fez o mesmo jeito, e o meu deu certo.

  • o meu deu o mesmo, mas fiz primeiro a mudança no dns digitalocean e depois fui no registro br e então deu certo. Está funcionando direitinho, porém depois que carrega o site, aparece meu ip no lugar do domínio, alguém saberia acertar este detalhe?

  • @vicentedecarlo esse meu problema também, estou usando nginx, eu consigo acessar pelo ip, agora estou tentando acessar pelo domínio e ainda não conseguir.

  • meu problema nao era na digital e nem no registro, mas no banco de dados do magento. Estava o ip no core config data e não o dominio, então o site abria mas no endereço aparecia o ip. troquei no banco de dados e ficou bom

  • Olá! Estou aprendendo essa parte toda de configuração e queria sabe o que colocar no MASTER e SLAVE1 lá do Registo BR.

    Eu teria que definir um dns no droplet e depois colocar o ns1.digitalocean.com como master e ns2.digitalocean.com como slave?

    Obrigado!

  • Pessoal o meu problema é que não posso usar o nome do Digital nos meus clientes entendem? Os clientes apontam para meu DNS e em outras revendas que usei sempre funcionou, porém na digital não consegui. Crio o NS com meu alies mas da o erro de consulta recusada. Alguém pode dar uma ajuda? Obrigado

  • Faz o seguinte, voce coloca o seu dns pra ele, mas tem que criar dentro do seu servidor o dominio dele, melhorando voce vai em networking e adiciona o dominio dele.. e deixa configurado seu n1 de apontamento certinho.

4 Answers

estava com o mesmo problema,
mas resolvi
você vai no painel de controle > networking > adiciona o dominio e salva
depois volta no registro br e salva novamente

Assim como @tiagoffssantos mencionou. É necessário adicionar o domínio ao seu droplet primeiro no painel da DigitalOcean, e só depois adicionar os nameservers no registrobr

Pessoal,

Acabei conseguindo depois que removi o www, como sugeriu o luizpaulo165 .

Abs,

Have another answer? Share your knowledge.