Question

Disable anchor IP

I noticed that my VM has a private IP attached to the primary interface alongside the public IP.

I’m attempting to setup Hashicorp Consul which is advertising this IP which doesn’t work because the IP doesn’t resolve.

Is there a way to disable this setting as I have no intention of using floating IPs with these VMs.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi there,

This private IP address comes from the default VPC that each new Droplet is part of. I believe that there is no way to disable the default VPC.

However, what you could do is specify the interface that the consul agent binds on, as per the documentation here:

https://www.consul.io/docs/agent/options

Let me know how it goes! Regards, Bobby