Question

Discourse 1-click vps ip cant be accessed.

Hi;

I’ve purchased a VPS from digital ocean and used there one click install for discourse droplet.

After entering the domain name etc. and doing the standard set up. Every time I go to my vps ip address (discourse has been installed on the main domain which I’ve pointed to the vps ip). Every time I go to the vps ip. It keeps saying:

This site can’t be reached (MY-VPS-IP) refused to connect.

Try:

Checking the connection [Checking the proxy and the firewall] ERR_CONNECTION_REFUSED

I’ve opened the http and https ports as well and thats showing as open when I run the sudo ufw status command.

I’ve tried clearing my cache in case its a browser local issue; but still no luck.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

I just tested this with the latest version of the Discourse 1-Click installation and it seems to be working now as expected.

There are a few things that you need to keep in mind:

  • If you specify a domain name that has been recently pointed to your Droplet’s IP address, note that it might take a while for the DNS to propagate over the Globe
  • If you do not have a domain name yet, you could use the IP as the hostname during the setup
  • Make sure that the credentials for the SMTP server are correct

Regards, Bobby