Question

DNS Error Present (CNAME (illegal))

Hello there,

I`ve this error on my DNS menu:

zone moon.bg/IN: NS ‘NS1.MOON.BG’ is a CNAME (illegal) zone moon.bg/IN: NS ‘NS2.MOON.BG’ is a CNAME (illegal) zone moon.bg/IN: not loaded due to errors.

Why this error come to me? I added the domain & NS servers before two weeks, but today I forwarded my domain to droplet. Is this the error and will be ready soon? What to do?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Are you putting your trailing dots after your Hostname within the A Record?

i.e; ns1.moon.bg**. **

Hi, thank you for the replay. First I want to say, that I made this settings the same for other my server “bulrose.bg”, which work perfect. I do it the same here, but there is error:

zone moon.bg/IN: NS 'NS1.MOON.BG' is a CNAME (illegal)
zone moon.bg/IN: NS 'NS2.MOON.BG' is a CNAME (illegal)
zone moon.bg/IN: not loaded due to errors.

Here is the screenshot of my DNS settings, which comes with DNS Error Present now:

LINK SCREENSHOT
Screenshot

It’s a bit hard to tell without knowing exactly what you have entered for your DNS records, but it sounds like you have tried to add a CNAME to ns1.moon.bg using the whole FQDN. What you want to enter is just ns1

Check out this tutorial for more information on how to setup DNS records using the DigitalOcean control panel.