DNS not resolving after updating the Nameservers of gagabytes.com.au to DO. web.gagabytes.com.au mx.gagabytes.com.au SPF are not resolving

June 20, 2019 148 views
DigitalOcean CentOS

nslookup web.gagabytes.com.au.

*** ad1.corp.systechmlr.net can't find web.gagabytes.com.au.: Non-existent domain

=============================
nslookup -q=mx gagabytes.com.au.

gagabytes.com.au
primary name server = ns1.digitalocean.com
responsible mail addr = hostmaster.gagabytes.com.au
serial = 1561011523
refresh = 10800 (3 hours)
retry = 3600 (1 hour)
expire = 604800 (7 days)
default TTL = 1800 (30 mins)

2 Answers

Hi,

Everything looks ok for the parent domain "gagabytes.com.au" when I try my own ns lookups but does not look like any other records beyond the basics have been setup.

After switching to a new DNS provider like DIgitalOcean you'll need to create any additional records like "www" or "web" hostnames, or MX records.

Here's a link to the Quick Start doc on using DO's DNS administration panel in Cloud:

https://www.digitalocean.com/docs/networking/dns/quickstart/

It contains links to other docs and tutorials for tasks like setting up new hostnames or MX records.

Hope this helps, let us know if you have any more questions :)

  • I had already installed WHM cPanel and updated the records more than 12 hours back. Only domain is resolving but the other records resolving to SOA records. I had checked the DNS file and records are present but it's not resolving. Updated SPF too but not working.

    • I'm not overly familiar with WHM cPanel but I believe the DNS management inside of cPanel only works when the server it is running on is also the DNS server that the domain is delegated to.

      Currently, your domain is delegated to DigitalOcean's name servers so only changes you make via your DigitalOcean Cloud account or API will take effect.

Have another answer? Share your knowledge.