Question

DNS - problem with digital ocean servers?

Posted July 13, 2021 154 views
DNS

If we use mxtoolbox.com to test our config, one moment an MX record check of the domain concerned shows the correct entry. Refresh in mxtoolbox.com and it shows an old record from two days ago.
When logged into digitalocean the MX record shows the correct entry. It is almost as if the settings in digitalocean as visible when logged in aren’t properly published to the actual name servers ns1 ns2 and ns3.
Anyone else has this issue?
How can we check on this?

1 comment
  • Hey there! I haven’t been able to replicate this. Can you provide the domain name you are seeing these issues on? If you don’t want to share it here feel free to open a ticket with that info and we can take a look.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

it’s for pendukasafaris.com
Just tested again. three times a refresh with a minute inbetween and it shows the correct settings. A forth refresh in mxtoolbox and it shows the old settings again. A few more subsequent ones also show the old record settings.

Hello, @tomafrica

Keep in mind that DNS changes might take up to 24 hours in order to fully update due to DNS cache and general DNS propagation time.

You can use our DNS check tool to see if you get the correct DNS records.

https://www.digitalocean.com/community/tools/dns?domain=pendukasafaris.com

Regards,
Alex