Question

DNS redirect with CNAME blocked on app

Posted December 16, 2021 80 views
DNS

Hi,

I have a domain with a CNAME pointing to an APP on digitalocean.
The CNAME points correctly by the provider and is active in the control panel on digitalocean, but for some reason the redirect gets blocked by digitalocean. Here is the link: https://mxtoolbox.com/SuperTool.aspx?action=cname%3a+++hedgecoin.city&run=toolpage

Can someone please help me understand how to fix it? I have tried with other domain-names following the same procedure and they work. I have also waited long enough for DNS-changes to propagate.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hey there!

Is this site using App Platform or hosted on a droplet? It looks like that domain is using DigitalOcean nameservers. If this is an app on App Platform you don’t need to configure any DNS settings for the app directly. You would delete any A records you created then manually add the domain under the domains settings of your app. App Platform would then automatically create the correct DNS entries to point your domain to your app.

App Platform DNS

Hope it helps!
Nate

  • Hi Nate,

    Thank you for your answer.

    The site is using the App Platform and I have registered the domain that is not working in the domains-settings for the App Platform using the CNAME option.

    I also have another domain connected and active pointing to the app hosted through the same service-provider as the one I cant get working. I have this as the top custom domain for the app inn the App Platform domains settings. I have added them both the same way, using the “you manage your domain” option, and have entered identical information in the service-provider DNS-settings(CNAME).
    As one is working, the other one should as well…

    As per now the main domain has Status of active and the other is on an eternal “Configuring…” loop in the App Platform settings. At one point they were both active, but when trying to reach the app through the second domain name then, I still got an Error 500 in the browser.

    I have left both settings on CNAME now as they were when I originally posted the question above. I deleted the CNAME records and tried using the DigialOcean Nameservers as you say, to no avail. As DNS-changes takes a bit of time to propagate, it was probably on this setting when you checked.

    I have talked with the service provider and they said that everything is working on their end, but that somehow DigialOcean blocks the CNAME.

    Appreciate the help!
    Torstein