Question

domain names not working in Vesta

Hi all,

I have setup my VPS on Ubuntu and VestaCP. All seems fine with my main domain name but when I add new sites into the VestaCP they don’t seem to work?

webba.co.uk is my main domain. I added rafflerocket.co.uk to the CP but the page doesn’t display.

any help would be great!

thanks.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have a similar problem. I have set up a domain but the page that displays for it is not the one in: root@vesta:/home/admin/web/mydrupalsite.co.uk/public_html# index.html instead it shows an irritating page with It worked! Powered by VESTA . This would of course not be irrittating if it was the right page but it is not :)

Any advice appreciated

Malcolm

If you are looking to host multiple websites, you seems to have it setup correctly. You simply need to add the your html files to the public_html folder for domain name rafflerocket.co.uk. Which is located under /home/<user>/web/rafflerocket.co.uk/.

If you are trying to serve same website for both webba.co.uk and rafflerocket.co.uk. You first have to delete the web account for rafflerocket.co.uk. Then go to webba.co.uk settings and add rafflerocket.co.uk under aliases.