Domain won't connect to droplet server. DNS issue?

March 4, 2018 823 views
DNS Networking Ubuntu 16.04

I'm having - what I think - are DNS issues.

My droplet is functioning. I can hit it at the IP address. My domain is registered at Network Solutions and my nameservers are pointing to ns1.digitalocean.com, ns2.digitalocean.com, ns3.digitalocean.com. I've setup A records. I can ping the IP address and the domain on the command line, and all seems well.

Hitting the domain returns a server connectivity error.

I'll probably need to provide more info, I just don't know what that might be.

Relatively new to DNS. Need help! Thanks.

2 comments
  • Do you see your Droplet's IP address when you ping the domain name? What happens when you try to browse to http://your droplet's IP address?

  • Hi Kamal,

    I've actually just located the source of the problem and resolved it. It was, in fact, some unconfigured settings in my ServerPilot setup causing the issue.

    Embarrassingly simple fix after a days worth of agonizing.

    I appreciate you taking the time to try and help me out!

1 Answer

This question was answered by @brettc85ef22842dd6f6d8eea6:

Hi Kamal,

I've actually just located the source of the problem and resolved it. It was, in fact, some unconfigured settings in my ServerPilot setup causing the issue.

Embarrassingly simple fix after a days worth of agonizing.

I appreciate you taking the time to try and help me out!

View the original comment

Have another answer? Share your knowledge.