Error - Invalid Size Specifies

Hi friends, I’m getting the error invalid size specified,

what could be the cause of this?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I had the same error this week, and was informed by support that my account had a limit set on it which prevented creating volumes larger than 100GB. They have passed it on to engineering support and assume they will increase my limit… I hadn’t had to use droplets for around 8 months until now, and this limit was not in place back then. Wonder if it’s just an arbitrary resource management setting that’s been put in place, if digitalocean is getting more popular.

This comment has been deleted

    Still getting the same error. Steps taken:

    1. Create -> droplet
    2. Region - New York (tried others but same result), datacenter - NYC1
    3. Image - default ubuntu 22.10 x64
    4. CPU - shared, regular with SSD, 2 GB / 2 CPUs 60 GB SSD Disk 3 TB transfer
    5. 200GB of volumes
    6. Added a SSH key Done

    This gives the above error

    Try DigitalOcean for free

    Click below to sign up and get $200 of credit to try our products over 60 days!

    Sign up

    card icon
    Get our biweekly newsletter

    Sign up for Infrastructure as a Newsletter.

    Sign up
    card icon
    Hollie's Hub for Good

    Working on improving health and education, reducing inequality, and spurring economic growth? We’d like to help.

    Learn more
    card icon
    Become a contributor

    You get paid; we donate to tech nonprofits.

    Learn more
    Welcome to the developer cloud

    DigitalOcean makes it simple to launch in the cloud and scale up as you grow – whether you’re running one virtual machine or ten thousand.

    Learn more ->
    DigitalOcean Cloud Control Panel