Question

error: /var/lib/dpkg/info/systemd.postinst: 133: /var/lib/dpkg/info/systemd.postinst: cannot open /run/systemd/was-enabled: No such file

With ubuntu 14.04; does anyone know why /run/systemd/was-enabled does not exist and is expected?

Thanks …

Richard

sudo apt-get install uwsgi
[sudo] password for admin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libjansson4 libmatheval1 libpgm-5.1-0 libsodium13 libzmq3 uwsgi-core
Suggested packages:
  nginx-full cherokee libapache2-mod-proxy-uwsgi libapache2-mod-uwsgi libapache2-mod-ruwsgi uwsgi-plugins-all uwsgi-extra
The following NEW packages will be installed:
  libjansson4 libmatheval1 libpgm-5.1-0 libsodium13 libzmq3 uwsgi uwsgi-core
0 upgraded, 7 newly installed, 0 to remove and 3 not upgraded.
4 not fully installed or removed.
Need to get 949 kB of archives.
After this operation, 3,126 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://mirrors.digitalocean.com/ubuntu/ vivid/main libjansson4 amd64 2.7-1ubuntu1 [27.3 kB]
Get:2 http://mirrors.digitalocean.com/ubuntu/ vivid/universe libmatheval1 amd64 1.1.11+dfsg-2 [21.2 kB]
Get:3 http://mirrors.digitalocean.com/ubuntu/ vivid/universe libpgm-5.1-0 amd64 5.1.118-1~dfsg-2ubuntu1 [158 kB]
Get:4 http://mirrors.digitalocean.com/ubuntu/ vivid/universe libsodium13 amd64 1.0.1-1 [134 kB]
Get:5 http://mirrors.digitalocean.com/ubuntu/ vivid-updates/universe libzmq3 amd64 4.0.5+dfsg-2+deb8u1build0.15.04.1 [140 kB]
Get:6 http://mirrors.digitalocean.com/ubuntu/ vivid/universe uwsgi-core amd64 2.0.7-1ubuntu2 [454 kB]
Get:7 http://mirrors.digitalocean.com/ubuntu/ vivid/universe uwsgi amd64 2.0.7-1ubuntu2 [14.9 kB]
Fetched 949 kB in 0s (1,434 kB/s)
Setting up systemd (219-7ubuntu6) ...
/var/lib/dpkg/info/systemd.postinst: 133: /var/lib/dpkg/info/systemd.postinst: cannot open /run/systemd/was-enabled: No such file
Failed to try-restart systemd-logind.service: Connection timed out
Failed to try-restart systemd-networkd.service: Connection timed out
Failed to try-restart systemd-resolved.service: Connection timed out
Failed to try-restart systemd-timesyncd.service: Connection timed out
Selecting previously unselected package libjansson4:amd64.
(Reading database ... 97191 files and directories currently installed.)
Preparing to unpack .../libjansson4_2.7-1ubuntu1_amd64.deb ...

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @domcamilliere:

So as strange as it is. I restarted my droplet and tried again and thankfully it worked!

View the original comment