Error when using PPTP server on VPS: compressor dropped pkt

Posted May 3, 2014 8k views
Hello, when setting up my VPN I used this tutorial: It works but when I connect to it, it is very slow and only a few websites load. I have gone and viewed the logs file for errors and it says: PPP: compressor dropped pkt I've tried the same thing on another droplet but I get the same problem. Also, I have tried searching Google but the only results I get aren't for Ubuntu. If anyone has any advice I'd appreciate it and follow through. For the time being, I am using openvpn connect.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers
Hey guys, I've fixed the problem, You've gotta do:

Below is my workaround script, place it into file '/etc/ppp/ip-up.d/mppefixmtu' and ensure that it is executable ('chmod +x mppefixmtu'):

CURRENT_MTU="`ifconfig $1 | grep -Po '(?<=MTU:)([0-9]+)'`"
ifconfig $1 mtu $FIXED_MTU
echo "Increased MTU for $1 to $FIXED_MTU (from $CURRENT_MTU) to fix MPPE Microsoft Point-to-Point bug #330973"

Taken from:
The comment's didn't work so just go to:


I had the same problem on centos 6.5, some pages simply wont load, however I just added

ifconfig $1 mtu 1400

to /etc/ppp/ip-up and it worked